I've edited a couple of questions today on the main Webmasters site for re-tagging, and the field is no longer providing the suggestions drop-down. As a quick test to make sure I wasn't expecting something that never happened, I tried over on the main SO site, and it does work over there.

This is edit-only, as far as I can tell. The suggestions drop-down does appear when authoring a new question.

Didn't think to check the console previously, for some reason. Firefox 4 reports:

Error: bindTagFilterAutoComplete is not defined Source File: [question URL] Line: 2
| |
  • Can you try if it works now, please? – balpha Jul 13 '11 at 11:58
  • 1
    @balpha Working now. Thanks. – Su' Jul 13 '11 at 16:53
  • Great, thanks for testing. – balpha Jul 13 '11 at 18:14

I suspect a timing issue between the loading and execution of JavaScript files. We've seen issues like this previously; they are hard to reproduce reliably across machines.

In addition, this particular autocomplete issue would only appear for non-moderators between 2000 and 2999 reputation (you fall into these boundaries on Webmasters, as does another user on Super User who reported the same issue).

So while this is indeed , it's plausible; we'll have a look at trying to avoid these timing issues.

Update: We've made a change to how the JavaScript is loaded, and since both you and the other user report it's working now, I guess my suspicion was right.

| |
  • 1
    That's...highly specific. Making it precisely the kind of bug I tend to wind up running into. Now to go troll for some rep points so it stops grin – Su' Jul 12 '11 at 21:35
  • That's the spirit! – balpha Jul 12 '11 at 21:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .