2

I've just noticed this whilst attempting to fix the formatting of the numbered list in this question, but I can't!?

UPDATE: Sorry, I thought this problem was more general at first, however, it only seems to be affecting that one question/answer!? Answering or editing other questions on Pro Webmasters (or other sites) appears to be OK.

Something strange is happening after the second list item in a numbered list.

The third list item in a numbered is appearing as a sub list, ie. indented. In the preview window this gets the number 1 (as in a regular sub list). However, in the submitted text, this correctly gets the next number from the parent list, ie. 3 - however, it is no longer seen as a list item, unless you've included a line gap between list items, in which case it is still indented like a sub list. (?!)

Bizarrely I can't seem to mark up the section as code (or a quotation), the problem still occurs and breaks the code block.

Here's a screenshot of the edit window and preview. The third list item is being rendered as an ordered sub list.

Edit window number list

When this is posted, then it appears differently (screenshot below). The 3. appears to be a literal 3. in the rendered output, which is now part of the second list item - there is no sub list in the rendered output.

Posted rendering

However, if you'd entered a line gap between list items in the editor, then the final rendering appears different again (screenshot). Actually, the rendered HTML is not so different to above. The third list item has become part of the second (although a literal 3. is written) and the indentation is the result of 2 spaces prefixed to the text.

Posted rendering with line gaps

I've tried this on StackOverflow and WebApps and it appears OK.

  • I've had problems with marking up and creating numbered lists too. In the past I resorted to using a parenthesis around the number, like: 1.) 2.) 3.) Otherwise subsequent edits could change the numbered sequence. – dan Sep 4 '14 at 8:08
  • @dan: I've just noticed that this particular problem seems to be isolated to that one question/answer!? – MrWhite Sep 4 '14 at 8:21
  • The issue might have been that each line of the numbered list needed to be indented exactly one space. I applied that to the question and it seems to work OK. Where I've had an issue before is adding another (unnumbered) line between list items. In that case, you need a parenthesis. – dan Sep 4 '14 at 8:38
  • Check your test answer, it had a two spaces before each number, and removing one space fixed it. – dan Sep 4 '14 at 8:44
  • Go ahead and remove the "bug" tag if you're satisfied (or you can delete the question if you think it's going to confuse others). – dan Sep 4 '14 at 8:45
  • @dan Hhhmm, that's weird - I definitely checked the number of spaces (tried no-space, 1 space and 2 spaces)?! After you've edited it, it now works OK and I can now edit it again and enter 2 spaces and it's still OK! Well, whatever it was, it does appear to have been a temporary problem at my end then I guess - eesh! lol. Thanks for that. Just a thought... I did initially copy the question text into the answer and edited that - maybe I copied a "funny" character?! – MrWhite Sep 4 '14 at 8:55
  • NP. I saw it occur too, so you didn't imagine it :-) Maybe there was something invisible in there(?) Still waiting for a response on the Review cue issue. – dan Sep 4 '14 at 8:59
  • 1
    @dan I can't actually remove the "bug" tag (since it must have one of "those" tags to be posted). Can you add "status-bydesign" (or something?). I think I have found what the cause of this problem was... there is indeed a strange character before the "3." in the original post (which I copied). However, this is zero-width (ie. invisible - to me anyway!?) in the editor and I can't delete it for some reason. However, if I copy the text into another editor (Notepad++) I can see the strange char (a square block), remove it, paste it back and it's OK. – MrWhite Sep 4 '14 at 9:31
  • @dan However, I'm guessing you actually saw this "strange" character as a "space" in the editor and could simply delete it? Maybe there's a difference in encodings or something? – MrWhite Sep 4 '14 at 9:32
  • I see. Perhaps when I was removing the indent spaces the invisible character got deleted. Tagged it with status-bydesign so it's no longer considered an open bug for the Community Team. – dan Sep 4 '14 at 9:48
1

Just to wrap this question up... there was a "funny" unicode character in the question source that I was unable to see/edit which was breaking the markdown output. (I had also inadvertently copied this same text into another answer which also copied the "funny" character.) On the Pro Webmasters website this did not show at all for me in the editor and I could not delete it. Using Google Chrome on Windows 7.

However, if I copied the text into an external editor (such as Notepad++), the "funny" character was visible as a square block:

Funny character appears as square block in external editor

Analysing this character in a hex editor revealed the 3 bytes E2 80 A8 which is unicode code point U+2028 (LINE SEPARATOR).

Analysing funny character in hex editor

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .